• Advertisement

Call connector for Dynamics CRM - No dial button

This is for more general topics about networking and vendors.

Call connector for Dynamics CRM - No dial button

Postby Guest » Sun Jul 11, 2010 6:20 am

Hi,

 

Ive set up a UC520 with Call Connector for Dynamics CRM and am having a few teething problems.

 

Ive got it installed, the searching an dialing from the system menu is working fine. The problems Ive got firstly is that there is no Dial button appearing on any of the CRM forms. ISV Integrations are enabled, there just doesn seem to be any changes made during installation. I have run the installer again.

 

Secondly I am having trouble getting the phones to lookup from the CRM database. This is mostly due to my lack of knowledge of setting up an IP Phone Lookup Service, if you could point me in the direction of some documentation Id be grateful.

 

Thanks,

 

Adam

Guest
 

Advertisement

Re:Call connector for Dynamics CRM - No dial button

Postby Guest » Sun Jul 11, 2010 6:23 am

Hi Adam,


Can you please open a TAC case for this issue?

 

Thanks,


Marcos

Guest
 

Re:Call connector for Dynamics CRM - No dial button

Postby Guest » Sun Jul 11, 2010 6:34 am

I have sorted this - details in case any one else has this problem are:

 

If buttons do not appear on CRM forms, firstly check that ISV Integrations are active - details for this are in the installer PDF.

 

Export customizations by logging on to CRM as an Administrator user and Selecting Settings, and then Customization from left menu. Click Export Customizations from the workpane and export ISV Config.

 

Extract the customizations.xml file and edit it to insert the following code into the Account, Lead and Contact Tool bars, obeying normal MSCRM rules and placement.

 

            <Button Icon="/_imgs/ico_16_137.gif" Url="http://servername:5556/CUCCdial.aspx" PassParams="1" WinParams="" WinMode="0">
              <Titles>
                <Title LCID="1033" Text="Dial" />
              </Titles>
              <ToolTips>
                <ToolTip LCID="1033" Text="Dial Account" />
              </ToolTips>
            </Button>

 

Adam

Guest
 

Re:Call connector for Dynamics CRM - No dial button

Postby Guest » Sun Jul 11, 2010 7:09 am

Make sure you read the install guide in the zip file with the installers on how to setup the XML application to show CRM Contacts on the phones.

The Dial button shows up on CRM pages, as an add on, as long as the server piece was installed correctly with admin rights.

The install guide on CCO, under CallConnectors for CRM is out of date for setting up the XML app on the phones, so make sure you use the admin guide in the zip file instead.

 

Ron Lewis

Cisco

Guest
 

Re:Call connector for Dynamics CRM - No dial button

Postby Guest » Sun Jul 11, 2010 7:59 am

Hi,

 

1.Could you finally get the IP Phone lookup service working. If yes can you send me the steps?

 

2.I am havig issue with outbound dial(click to dial), which I think is due to the TAPI configuration:

 

Questions:

 

1.Do I need to install Cisco TAPI TSP Driver?

 

2. Do I need to manually create CTI ports in CCM?

 

3.Is CTI Route point also needed?

 

Any other thing to check?

 

Thanks

Guest
 



  • Advertisement


Similar topics


Return to Anything Networking

Who is online

Users browsing this forum: No registered users and 4 guests