• Advertisement

OSPF in VRF with same area ID

Static, RIP, EIGRP, OSPF, BGP, IBGP, IS-IS and any other routing.

OSPF in VRF with same area ID

Postby Guest » Fri Jan 22, 2010 7:10 am

Hello all,

 

On an MPLS/VPN PE router, I have configured OSPF as the PE/CE routing protocol.

I configured several OSPF processes one for each VRF.

But if I have several customers who are using the same OSPF area ID on the CE side, may I configure the same area ID for several OSPF processes on the PE side ? Of course, all of those areas are independent and I don want to see customer1s routes into the OSPF of customer2 !

 

In the following example, I have 2 customers. Each customer has got 2 sites and has an OSPF backbone area which is spread accross his 2 sites. For each customer, I want to interconnect his 2 sites and extend OSPF backbone area across MPLS.

The OSPF backbone area of customer1 is different from the one of customer2, even if the ID is the same...

 

Here is a sample of the PEs configuration :

 

interface G0/1

ip vrf forwarding customer1

ip address 10.1.1.1 255.255.255.0

!

interface G0/2

ip vrf forwarding customer2

ip address 10.1.2.1 255.255.255.0

!

!

router ospf 1 vrf customer1

network 10.1.1.0 0.0.0.255 area 0

!

router ospf 2 vrf customer2

network 10.1.2.0 0.0.0.255 area 0

 

Won I experience problems if I use the same area ID there ?

 

Thanks for your help !

Guest
 

Advertisement

Re:OSPF in VRF with same area ID

Postby Guest » Fri Jan 22, 2010 7:45 am

Hello Sam,

 

You won face any problem because you have configured cust1 and cust2 under vrf instance within ospf.There will not be any

mixing of routes between cust1 and cust2.

 

In addition to that also configure domain-id (a /32 unique ip address) under ospf process for each customer. The reason if you configure ospf process

id 1 for cust1 at A-End and if you configure process id 2 for same customer on B-end the routes propogated from A-end will be seen as

inter-area at B-end

 

router ospf 1 vrf customer1

ospf domain-id 1.1.1.1 >>> keep this same for this vrf at every site

network 10.1.1.0 0.0.0.255 area 0

 

Hope this is helpful

 

Regards

Mahesh

Guest
 

Re:OSPF in VRF with same area ID

Postby Guest » Fri Jan 22, 2010 8:02 am

Mahesh you said this :

 

"[...] In addition to that also configure domain-id (a /32 unique ip address) under ospf process for each customer. The reason if you configure ospf process id 1 for cust1 at A-End and if you configure process id 2 for same customer on B-end the routes propogated from A-end will be seen as inter-area at B-end [...]"

 

I guess you mean :

 

  • If OSPF domain-id is not the same on PE at both ends, the routes will be exported within type-5 external LSA at B-end
  • If OSPF domain-id matches on PE at both ends, the routes will be exported within type-3 inter-area LSA at B-end.

 

Thanks.

Guest
 

Re:OSPF in VRF with same area ID

Postby Guest » Fri Jan 22, 2010 9:04 am

Hi Sam

 

For more detail You can refer the document that i had shared . below is the link .

 

Here you will get clear picture of OSPF with Domain ID & Process ID.

 

 

OSPF with unique process = O IA (OSPF Route)

 

OSPF with different process = O E2 (OSPF Route)

 

OSPF with unique Process ID but different domain ID = O E2 (OSPF Route)

 

OSPF with different process ID but unique domain ID = O IA (OSPF Route)

 

https://learningnetwork.cisco.com/docs/DOC-8648

 

 

Regards

Chetan Kumar

http://chetanress.blogspot.com

Guest
 

Re:OSPF in VRF with same area ID

Postby Guest » Fri Jan 22, 2010 9:16 am

Yes you are right you can use; for every customer you can use the same area; this is the main advantage of using MPLS. For domain id you can check the post which tells about to use the domain-id for receiving routes from same customer. By default domain-id is changed for every vrf per PE and you receive one CPE routes to another CPE routes of same vpn as external routes. Please check my post for domain-id:-

 

http://www.mplsvpn.info/2008/11/why-ospf-vpnv4-routes-look-as-external_07.html

 

 

regards

Shivlu Jain

Guest
 



  • Advertisement


Similar topics

using a hsrp address with ospf?
Forum: Anything Networking
Author: Anonymous
Replies: 2

OSPF database-filter all out question
Forum: Anything Networking
Author: Anonymous
Replies: 0

Maximum amount of OSPF Routes in CSS 11506
Forum: Anything Networking
Author: Anonymous
Replies: 0

ospf-bgp repair
Forum: Anything Networking
Author: Anonymous
Replies: 3

Routes in RT, but not in OSPF database
Forum: Anything Networking
Author: Anonymous
Replies: 0


Return to Routing Protocols

Who is online

Users browsing this forum: No registered users and 1 guest

cron