• Advertisement

RVS4000 disabling IPS kills DNS

Linksys, Netgear, sonicwall, ect. Webbase configurations for routers.

RVS4000 disabling IPS kills DNS

Postby Guest » Sat Dec 25, 2010 3:20 am

Background: I recently bought a couple of RVS4000 routers set up a VPN between my home and office. Initial setup went great and I got the VPN working with Dynamic DNS at both ends quite easily. The only problem was that the performance sucked badly; my ISP gives me 45Mb/s and a frequently see this in both directions from both speed test sites and SFTP to other servers, and they are planning to upgrade our building to 100Mb/s next month. With the RVS4000 in place I typically get 12Mb/s download and 7Mb/s down. No problem, I thought. Ive read that most of the performance problems come from the Intrusion Prevention System having to look at every packet. So I switched the IPS off...

 

Problem: The problem I am having is that if I switch the IPS off then DNS breaks on every computer on the network :- Look-ups go so slowly that my web browsers frequently time out. If I access somewhere by IP address then everything is fine and the throughput of the router is acceptable (Ive see 28Mb/s when Ive actually managed to get resolve the address of a speed test server. Unfortuantely this doesn do me much good if I have no DNS. I restored the factory configuration for one router and then ran tests after each step of the configuration. Everything was fine until I switch the IPS off. I then restored to factory state again, confirmed everything was fine and changed nothing else except the IPS; when I disabled IPS the DNS died again!

 

Question: Is there any work-around for this? I pay for 100M/s wiring between my home and office and with the IPS enabled Im loosing 90% of the performance. If I disable the IPS the device is essentially useless. HELP! Any suggestions welcome. If I can fix this soon the routers are going to have to go back for a refund.

Guest
 

Advertisement

Re:RVS4000 disabling IPS kills DNS

Postby Guest » Sat Dec 25, 2010 4:20 am

NIck, What firmware version are you running on the rvs4000 router?

Guest
 

Re:RVS4000 disabling IPS kills DNS

Postby Guest » Sat Dec 25, 2010 5:59 am

The routers came with 1.2.11, which seems to be the latest I can find.

Guest
 

Re:RVS4000 disabling IPS kills DNS

Postby Guest » Sat Dec 25, 2010 6:58 am

Where are you pointing your dns?  Are you pointing it internally or are you pointing it to your isp.  You might try changing the dns servers to possibly 4.2.2.1 or 4.2.2.2 and see if that resolves the issue.

Guest
 

Re:RVS4000 disabling IPS kills DNS

Postby Guest » Sat Dec 25, 2010 8:21 am

The router is being given DNS settings as part of its DHCP configuration (as it happens the servers are 204.14.152.2 and ...5) so the router DNS is pointing to the ISP. The client machines are all getting DHCP from the router and this comes with DNS settings too. Typically they are receiving these same ISP addresses, although it seems that the sometimes get given the address of the router instead. I will try manually forcing them to 4.2.2.1 and ...2 once Ive had another cup of coffee.

Guest
 



  • Advertisement


Similar topics

What is the impact of disabling xlate in FWSM
Forum: Cisco Security
Author: Anonymous
Replies: 8

Disabling weak protocols in ACS 4.2?
Forum: Anything Networking
Author: Anonymous
Replies: 0

Disabling nat-control on a "live" firewall
Forum: Cisco Security
Author: Anonymous
Replies: 0

RVS4000 IP Access Lists
Forum: Small Business Routers
Author: Anonymous
Replies: 0

RVS4000 with Windows 2003
Forum: Small Business Routers
Author: Anonymous
Replies: 0


Return to Small Business Routers

Who is online

Users browsing this forum: No registered users and 1 guest