• Advertisement

OnConnect scripting issue from WEBVPN AnyConnect portal

IPsec, L2TP, Split tunneling, PPTP and all other VPN related posts.

OnConnect scripting issue from WEBVPN AnyConnect portal

Postby Guest » Mon Jan 10, 2011 2:53 pm

I have a minor issue

 

client is 2.5.0217

 

OnConnect script works great through the anyconnect client however if I use the web ssl front end to launch the anyconnect client the onconnect script does not run. Is there any way to have onconnect and ondisconnect scripts to run if the anyconnect client is launched through the webvpn.

 

I have searched high and low but with no luck. Anythoughts or ideas would be greatly appreciated.

 

thanks

Guest
 

Advertisement

Re:OnConnect scripting issue from WEBVPN AnyConnect portal

Postby Guest » Mon Jan 10, 2011 3:43 pm

Hi,


As per my understanding of the issue, i see that the script does not run when Anyconnect is launched using portal.


It can be related to a  difficulty finding the profiles at times.


This is usually a result of not having a hostname and hostaddress configured in the existing profile. I think it may be a good idea to add

these values to your existing profile so we land on the right xml profile the first time.

Try to add the host entry as  with fqdn of ASA.

And let me know if it helps.

For clearing up the credentials in the dialog box when using AnyConnect I found one of the bug:-

CSCsx76993

Symptom:

 

User credentials are cached in preferences.xml  file when using Anyconnect client.  So when they relaunch Anyconnect,  the username appears in the client.

 

Conditions:

 

This is seen in all anyconnect clients.  This is a configurable option in the IPSec client.

 

Workaround:

 

Currently there is no workaround


And i can see it is resolved in 2.4.202 however i am not sure if its resolved in 2.5 also. For this i would like to hear from others.



Regards,


Shilpa

Guest
 

Re:OnConnect scripting issue from WEBVPN AnyConnect portal

Postby Guest » Mon Jan 10, 2011 5:09 pm

Thanks for the reply Shilpa. Updating the client to 2.5.2006 and adding both the hostname as the fqdn and host address as the fqdn worked on the scripting. The scripts now run from anyconnect as well as the webvpn (web portal).

 

I just finished my happy dance - LOL!

 

I am going to start a new thread on the clear dialog box on anyconnect and Award points and close this thread.

Guest
 



  • Advertisement


Similar topics


Return to Virtual Private Networks

Who is online

Users browsing this forum: No registered users and 4 guests